This panel searches content only in this space. To search content in all spaces, use the box at the upper right.


For overview information, see Discovery Environment on the CyVerse website.

DISCOVERY ENVIRONMENT USER MANUAL

Skip to end of metadata
Go to start of metadata

The Data window contains both input data files that are used in analyses and output data files that are returned as the result of completed analyses. Input data files can be uploaded or imported to your personal workspace from your desktop or from URL, as well as made available by other users in the Community Data folder and shared with others.

This section discusses how to organize and maneuver data files and folders in your Data window, including viewing and changing the file's info-type.

For information on using data files in your analyses, see Submitting an Analysis.

You can access and manage data from outside the DE as well. For more information, see Downloading and Uploading Data.

Opening the Data window

Click the Data icon to open the Data window.

Window icons

At the top right of each data, apps, or analyses window are icons to help you learn more about the DE, and manage the window's size and display.

Help: Click to open the FAQs page for the current window.

Layout: Resizes the window layout to half of the available desktop space and positions it either to the left (Snap Left) or right side (Snap Right) of the window.

Minimize, maximize, or close the active window.

Data menus

The Data toolbar helps you manage files and folders.

Upload menu

File menu

Edit menu

Download menu

Share menu

Metadata

Refresh

  • Refresh the Data window if results are not updating as expected.

Trash

Using the Data list

  • Click in the search field, or paste the path, to search for a file or folder.
  • Click a folder in the Navigation list to displays its contents (files and subfolders) in the middle column.
  • Click a checkbox in the middle pane to view details about the item in the Details section in the right column.

Viewing and selecting files and folders

The Navigation list in the left pane is where you navigate through data files and folders in your personal workspace.

Personal folder

Click your username folder to view the list of data items you own.

Community Data

View the list of data items that have been shared by other CyVerse account users.

Shared With Me

Click the Shared With Me folder (does not show if no one has shared any items with you) to view data items that have been shared with you by other users.

Trash

Click the Trash folder to view the list of deleted data items, empty the Trash folder to permanently delete all items in the folder, or delete selected items.

Saved filters

If you saved any search filters, the Saved filters folder is displayed below the Trash folder.

Favorites

The list of your favorite files and folders.

Understanding inaccessible data items

Data items that are inaccessible are displayed in red italicized font.

This may be due to special characters (' or ~) in the path or name, or system-level items, such as your iplant/home/shared folder or your home directory. These data items cannot be opened, renamed, moved, deleted, or accessed in any way. For more information, see Using Special Characters in the DE.

Helpful Links

On This Page:

Related Pages:

Sorting, adding, and hiding columns in the Data list

You can sort on any column in the Data list, and hide or show columns to customize the look of your Data list.

  1. Hover over the column header until a down arrow appears on the right side of the column, and then click the down arrow:
  2. Click the setting to use
    • To sort on the column, click either Sort Ascending or Sort Descending.
    • To hide or show a column, point to Columns, and then select or clear the checkbox for the column.

      Need to view the path?

      Icon

      Show the Path column to help you determine which file or folder to use in search results.

Using the Data actions icons

Each item in the middle section of the Data list displays icons to the right for actions you can take on the item. The actions that are available depend on the permissions to which you have been granted for the item:

(shared path folder)
(via public link)

Create a Shared Path Folder Link (folders only)
or
Share the item via Public Link (files only)

Share the item Via the Discovery Environment

Metadata: Add or edit metadata or select a metadata template

Add or retract comments about a file or folder

Viewing Details

Click the checkbox for a file or folder in the middle column to view information about it in the Details section on the right side of the Data window. The options that are available depend upon whether a file or a folder is selected.

File Details

Folder Details

Details OptionDescriptionFileFolder
Last ModifiedDate the item was last modified by the owner.(tick)

(tick)

Date SubmittedDate the owner shared it publicly with other CyVerse users.(tick)(tick)
PermissionsPermission level you have been granted for the item.(tick)(tick)
ShareDisplays whether the file or folder has been shared. If you are the owner, allows you to access the file or folder to share or change sharing permissions.(tick)(tick)
SizeSize of the file.(tick)(tick)
TypeFile type for the file.(tick) 
Info-TypeInfo-type for the file.(tick) 
md5 ChecksumUseful for comparing files and verifying the integrity of the downloaded file.(tick) 
Send toCoGe, Ensemble, or Newick files only. Allows you to send a genome file to CoGe or Ensembl, or a Newick file to the Tree Viewer. These commands are also available in the Share menu.(tick) 
Files(s)/Folder(s)Number of files and subfolders contained in the folder. (tick)
TagsAdd or delete a tag for a file or folder, or enter a description about the tag or data item.(tick)

(tick)

Basic process

To begin, you need the data files you want to use in your analysis. You can use any file in your personal, Community Data, or Shared With Me folder, or you can upload or import a data file to your personal folder. Once the data file is in your workspace folder or in the Community Data folder, you can:

Icon

It is also possible to manage data outside of the Discovery Environment using other tools, as documented in Downloading and Uploading Data.

  • No labels